WEB技术论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
热搜: ASP asp.net php
查看: 408|回复: 0
打印 上一主题 下一主题

易语言订单小票打印

  [复制链接]

534

主题

541

帖子

2044

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2044
跳转到指定楼层
楼主
发表于 2018-1-6 20:36:04 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
.版本 2

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕

_启动窗口.标题 = “充值小票打印工具 By:雨轩”
宣传1.内容 = 到文本 (读配置项 (取运行目录 () + “配置.ini”, “程序配置”, “宣传1”, ))
宣传2.内容 = 到文本 (读配置项 (取运行目录 () + “配置.ini”, “程序配置”, “宣传2”, ))
票头.内容 = 到文本 (读配置项 (取运行目录 () + “配置.ini”, “程序配置”, “票头”, ))

.子程序 _开始打印_被单击

打印机1.开始打印 (, , , , , )
打印机1.字体 = 编辑框1.字体
打印机1.写出 (编辑框1.内容)

打印机1.结束打印 ()

.子程序 _打印预览_被单击

.如果真 (编辑框1.内容 ≠ “”)

.如果真结束
编辑框1.内容 = “”
编辑框1.是否允许多行 = 真
编辑框1.加入文本 (“      ” + 票头.内容 + #换行符 + “=======================” + #换行符 + “充值类型:” + 充值类型.内容 + #换行符 + “充值号码:” + 充值号码.内容 + #换行符 + “充值金额:” + 金额.内容 + #换行符 + “充值时间:” + 时间.内容 + #换行符 + “=======================” + #换行符 + “充值姓名:” + 姓名.内容 + #换行符 + “=======================” + #换行符 + 宣传1.内容 + #换行符 + 宣传2.内容)


.子程序 _保存设置_被单击

写配置项 (取运行目录 () + “配置.ini”, “程序配置”, “宣传1”, 宣传1.内容)
写配置项 (取运行目录 () + “配置.ini”, “程序配置”, “宣传2”, 宣传2.内容)
写配置项 (取运行目录 () + “配置.ini”, “程序配置”, “票头”, 票头.内容)


ini配置文件格式

[程序配置]
宣传1=12
宣传2=1212
票头=12

爱仿站的中年人
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

|手机版|码农集营 ( ) 深圳龙岗交友群

GMT+8, 2018-11-7 18:27 , Processed in 0.101201 second(s), 22 queries .

Powered by 码农集营 X3.4

快速回复 返回顶部 返回列表