WEB技术论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
热搜: ASP asp.net php
查看: 503|回复: 0
打印 上一主题 下一主题

代付接口批量提交,易语言托盘事件,弹出菜单

  [复制链接]

534

主题

541

帖子

2044

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2044
跳转到指定楼层
楼主
发表于 2018-1-3 02:51:29 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式

.版本 2
.支持库 iext
.支持库 dp1
.支持库 spec
.程序集 窗口程序集_启动窗口
.子程序 __启动窗口_创建完毕
追梦_加载皮肤 (#皮肤_Aero)
.子程序 _按钮1_被单击
.局部变量 局_文件名, 文本型
.局部变量 局_读入数据, 文本型
.局部变量 局_第一次分割, 文本型, , "0"
.局部变量 局_i, 整数型
.局部变量 局_第二次分割, 文本型, , "0"
.判断开始 (通用对话框1.打开 () = 真)
    局_文件名 = 通用对话框1.文件名
    局_读入数据 = 到文本 (读入文件 (局_文件名))
    局_第一次分割 = 分割文本 (局_读入数据, #换行符, )
    .计次循环首 (取数组成员数 (局_第一次分割), 局_i)
        局_第二次分割 = 分割文本 (局_第一次分割 [局_i], “-”, )
        超级列表框1.插入表项 (, , , , , )
        超级列表框1.置标题 (局_i - 1, 0, 到文本 (局_i))
        超级列表框1.置标题 (局_i - 1, 1, 局_第二次分割 [1])
        超级列表框1.置标题 (局_i - 1, 2, 局_第二次分割 [2])
        超级列表框1.置标题 (局_i - 1, 3, 局_第二次分割 [3])
        超级列表框1.置标题 (局_i - 1, 4, 局_第二次分割 [4])
        超级列表框1.置标题 (局_i - 1, 5, “待提交”)
    .计次循环尾 ()
.默认
.判断结束

.子程序 _超级列表框1_右键单击表项
弹出菜单 (操作, , )
.子程序 重新提交
.局部变量 对方账号1, 文本型
.局部变量 对方户名1, 文本型
.局部变量 代付金额1, 文本型
.局部变量 开户行1, 文本型
.局部变量 batchno, 文本型
.局部变量 nonce, 文本型
.局部变量 secondtimestamp, 文本型
.局部变量 提交参数, 文本型
.局部变量 签名, 文本型
.局部变量 代付结果, 文本型
置随机数种子 ()
.如果真 (超级列表框1.现行选中项 > -1)
    对方账号1 = 超级列表框1.取标题 (超级列表框1.现行选中项, 1)
    对方户名1 = 超级列表框1.取标题 (超级列表框1.现行选中项, 2)
    代付金额1 = 超级列表框1.取标题 (超级列表框1.现行选中项, 3)
    开户行1 = 超级列表框1.取标题 (超级列表框1.现行选中项, 4)
    batchno = 编辑框1.内容 + 到文本 (取随机数 (100000000000, 99999999999))
    nonce = 到文本 (取随机数 (10000000, 99999999))
    secondtimestamp = 时间_到时间戳 (取现行时间 ())
    程序_延时 (10)
    提交参数 = “amount=” + 代付金额1 + “&bankname=” + 开户行1 + “&batchno=” + batchno + “&inacctname=” + 对方户名1 + “&inacctno=” + 对方账号1 + “&nonce=” + nonce + “&orgno=” + 编辑框1.内容 + “&secondtimestamp=” + secondtimestamp + “”
    签名 = 到大写 (取数据摘要 (到字节集 (提交参数 + “&key=” + 编辑框2.内容)))
    代付结果 = 到文本 (网页_访问S (“网关地址”, 1, 提交参数 + “&sign=” + 签名, , , , , ))
    调试输出 (代付结果)
    调试输出 (提交参数 + “&sign=” + 签名)
.如果真结束

.子程序 __启动窗口_将被销毁
置托盘图标 ({  }, )
销毁 ()

.子程序 __启动窗口_托盘事件
.参数 操作类型, 整数型
.如果 (操作类型 = #单击左键)
    _启动窗口.可视 = 真
    _启动窗口.位置 = 1
    置托盘图标 ({  }, )
.否则
    .如果 (操作类型 = #单击右键)
        弹出托盘菜单 (托盘)
    .否则
    .如果结束
.如果结束

.子程序 __启动窗口_位置被改变
.如果真 (_启动窗口.位置 = 2)
    可视 = 假
    置托盘图标 (#图片1, “QQ:190066120”)
.如果真结束

.子程序 __启动窗口_可否被关闭, 逻辑型
_启动窗口.可视 = 假
.如果真 (_启动窗口.位置 ≠ 2)
    置托盘图标 ({  }, )
    销毁 ()
.如果真结束

.子程序 _重新提交_被选择
重新提交 ()
.子程序 批量提交
.局部变量 代付结果, 文本型
.局部变量 提交参数, 文本型
.局部变量 签名, 文本型
.局部变量 i, 整数型
.局部变量 对方账号1, 文本型
.局部变量 对方户名1, 文本型
.局部变量 代付金额1, 文本型
.局部变量 开户行1, 文本型
.局部变量 nonce, 文本型
.局部变量 secondtimestamp, 文本型
.局部变量 batchno, 文本型
置随机数种子 ()
.如果真 (超级列表框1.取表项数 () ≤ 0)
    信息框 (“请先导入信息”, 0, “说明”, )
    返回 ()
.如果真结束

.计次循环首 (超级列表框1.取表项数 (), i)
    对方账号1 = 超级列表框1.取标题 (1, 1)
    对方户名1 = 超级列表框1.取标题 (2, 2)
    代付金额1 = 超级列表框1.取标题 (3, 3)
    开户行1 = 超级列表框1.取标题 (4, 4)
    batchno = 编辑框1.内容 + 到文本 (取随机数 (100000000000, 99999999999))
    nonce = 到文本 (取随机数 (10000000, 99999999))
    secondtimestamp = 时间_到时间戳 (取现行时间 ())
    程序_延时 (10)
    提交参数 = “amount=” + 代付金额1 + “&bankname=” + 开户行1 + “&batchno=” + batchno + “&inacctname=” + 对方户名1 + “&inacctno=” + 对方账号1 + “&nonce=” + nonce + “&orgno=” + 编辑框1.内容 + “&secondtimestamp=” + secondtimestamp + “”
    签名 = 到大写 (取数据摘要 (到字节集 (提交参数 + “&key=” + 编辑框2.内容)))
    代付结果 = 到文本 (网页_访问S (“网关”, 1, 提交参数 + “&sign=” + 签名, , , , , ))
    调试输出 (代付结果)
    调试输出 (提交参数 + “&sign=” + 签名)
.计次循环尾 ()

.子程序 _按钮2_被单击
批量提交 ()
.子程序 _作者_被选择
信息框 (“QQ:190066120”, 0, “作者”, )
爱仿站的中年人
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

|手机版|码农集营 ( ) 深圳龙岗交友群

GMT+8, 2018-11-7 18:27 , Processed in 0.086229 second(s), 23 queries .

Powered by 码农集营 X3.4

快速回复 返回顶部 返回列表