WEB技术论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
热搜: ASP asp.net php
查看: 457|回复: 0
打印 上一主题 下一主题

易语言中的MYSQL操作之超级列表框使用

[复制链接]

534

主题

541

帖子

2044

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
2044
跳转到指定楼层
楼主
发表于 2018-1-3 02:52:52 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式

.版本 2

.支持库 mysql

.支持库 iext

.支持库 CnCalendar

.支持库 spec



.程序集 窗口程序集_启动窗口

.程序集变量 MySQL句柄, 整数型

.程序集变量 记录集, 整数型

.程序集变量 记录行数, 长整数型

.程序集变量 索引, 整数型

.程序集变量 n, 整数型

.程序集变量 id, 文本型

.程序集变量 uid, 文本型

.程序集变量 key, 文本型

.程序集变量 url, 文本型

.程序集变量 stat, 文本型

.程序集变量 addtime, 文本型



.子程序 __启动窗口_创建完毕



MySQL句柄 = 连接MySql (“127.0.0.1”, “root”, “root”, “tpshop”, 3306)

.如果 (MySQL句柄 ≠ 0)

    标签1.标题 = “连接数据库状态:OK!”

.否则

    标签1.标题 = “连接数据库状态:连接失败!”

    返回 ()



.如果结束

刷新显示 ()





.子程序 刷新显示



超级列表框1.全部删除 ()

执行SQL语句 (MySQL句柄, “SELECT * FROM `tp_key`”)

记录集 = 取记录集 (MySQL句柄)

记录行数 = 取记录集行数 (记录集)



.计次循环首 (记录行数, n)



    读字段值 (记录集, “id”, id)

    读字段值 (记录集, “uid”, uid)

    读字段值 (记录集, “ukey”, key)

    读字段值 (记录集, “uurl”, url)

    读字段值 (记录集, “ustat”, stat)

    读字段值 (记录集, “addtime”, addtime)

    索引 = 超级列表框1.插入表项 (n - 1, , , , , )

    超级列表框1.置标题 (n - 1, 0, id)

    超级列表框1.置标题 (n - 1, 1, uid)

    超级列表框1.置标题 (n - 1, 2, key)

    超级列表框1.置标题 (n - 1, 3, url)

    超级列表框1.置标题 (n - 1, 4, stat)

    超级列表框1.置标题 (n - 1, 5, addtime)

    到下一行 (记录集)



.计次循环尾 ()





.子程序 _按钮1_被单击

.局部变量 sql, 逻辑型



sql = 执行SQL语句 (MySQL句柄, “insert into tp_key (uid,ukey,uurl,ustat,addtime) values('” + wbuid.内容 + “','” + wbkey.内容 + “','” + wburl.内容 + “',1,'” + 格式化日期 (取现行时间 (), “%y-%m-%d”) + “')”)

.如果 (sql = 真)

    刷新显示 ()

    信息框 (“添加成功!”, 0, “成功!”, )

.否则

    信息框 (“添加失败!”, 0, “错误!”, )

    返回 ()

.如果结束







.子程序 _超级列表框1_右键单击表项



弹出菜单 (操作, , )





.子程序 _删除_被选择

.局部变量 sql, 逻辑型

.局部变量 已选中的项目, 整数型, , "0"

.局部变量 i, 整数型





已选中的项目 = 超级列表框1.取被选择表项 ()



.计次循环首 (取数组成员数 (已选中的项目), i)

    调试输出 (到文本 (已选中的项目 [i]))

    sql = 执行SQL语句 (MySQL句柄, “delete from tp_key where id=” + 超级列表框1.取标题 (已选中的项目 [i], 0))

    .如果 (sql = 真)

        信息框 (“删除成功!”, 0, “成功!”, )

    .否则

        信息框 (“删除失败!”, 0, “错误!”, )

        跳出循环 ()

    .如果结束



.计次循环尾 ()



刷新显示 ()



.子程序 __启动窗口_按下某键, 逻辑型

.参数 键代码, 整数型

.参数 功能键状态, 整数型







.子程序 _按钮1_按下某键, 逻辑型

.参数 键代码, 整数型

.参数 功能键状态, 整数型



.如果真 (键代码 = #回车键)

    _按钮1_被单击 ()

.如果真结束

爱仿站的中年人
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

|手机版|码农集营 ( ) 深圳龙岗交友群

GMT+8, 2018-11-7 18:27 , Processed in 0.082458 second(s), 23 queries .

Powered by 码农集营 X3.4

快速回复 返回顶部 返回列表